El servidor WAMP no funcionará

imagenes

Estoy usando WAMP. Estuve fuera del negocio por dos semanas, estoy de vuelta e intentando comenzar mi wamp 2. BANG. No pasa nada. El icono W rojo aparece entre los iconos ocultos. Cuando hago clic en él, muestra todos los servicios fuera de línea.

  • Versión de WAMP: 2.1
  • APACHE: 2.2.17 (enviado con WAMP)
  • PHP: 5.3.4 (enviado con WAMP)
  • MYSQL: 5.1. 53 (enviado con WAMP)

  • Directorio de instalación de WAMP: lo puse en un directorio personalizado (no en la ruta predeterminada).

  • Evento MYSQL: Estoy usando Ruby on Rails y tuve un problema molesto sobre una cosa dll que falta. Lo reemplacé, pero después de eso utilicé sin problemas y limitaciones el WAMP.

Ideas:

  • Reinicie la computadora: mismo problema.
  • Skype activado: nunca uses Skype. Sin embargo está instalado.
  • Puerto 80 tomado: no, lo probé en el apache>Servicio.
  • Archivos de registro: los 3 vacíos. Hay líneas de varias semanas solamente.

Cada vez que lo inicio, muestra Desconectado, el icono es rojo y no puede iniciar ningún servicio. Intenté reiniciar el programa también. No pasa nada.

He publicado dos veces esto porque los chicos de stackoverflow sugirieron que esto estuviera aquí.


Tenemos varias respuestas

La mejor respuesta:

El problema no era lo del puerto 80. Ni lo de IIS que se menciona habitualmente. Tampoco ayudó varias reinstalaciones con diferentes trucos (por lo general, se eliminan los registros en regedit vinculados a wamp).

La solución era una especie de problema localhost.

Pasos:

  • Tratar – http://127.0.0.1 – si aparece la página de inicio de WAMP que estás en el camino correcto

  • Abra el archivo hosts con el Bloc de notas – c: / windows / system32 / drivers / etc / hosts

  • Asegúrese de que solo haya una línea sobre el host local como esta:

    127.0.0.1 localhost
    

    Esto no es bueno

    127.0.0.1 localhost
    1 localhost
    

    O tuve algo como esto (no puedo recordar exactamente):

     127.0.0.1 localhost :: localhost localhost127.0.0.1 
    
  • Guarde y cierre el archivo hosts y BANG. Funciona que


Otra respuesta


Fuente

Leave a Reply